autom4te: need GNU m4 1.4 or later

I was upgrading GD on one of my DirectAdmin box and I got into this error. Seems like one of the compilation program version is outdated therefore I have to update them manually.

wget ftp://ftp.gnu.org/gnu/m4/m4-1.4.9.tar.gz
tar zfx m4-1.4.9.tar.gz
cd m4-1.4.9
./configure –prefix=/usr
make
make install

At the same time, I will upgrade autoconf as well 🙂

cd /usr/src
wget http://ftp.gnu.org/gnu/autoconf/autoconf-2.61.tar.gz
tar xzf autoconf-2.61.tar.gz
cd autoconf-2.61
./configure –prefix=/usr
make
make install

Hope this help someone out there and as a reference for me in future 😉